Servers and applications
CVE-2018-1000300
curl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl < 7.54.1 and curl >= 7.60.0.
- Severity
- Critical 9.8
- Published
- 24 May 2018
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 21 Oct 2026
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
curlServers and applications · cpe:a:haxx:curl |
|