Servers and applications
CVE-2018-1000168
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
- Severity
- High 7.5
- Published
- 8 May 2018
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 21 Oct 2026
- Fixed in
- 10.4.1
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
Node.jsServers and applications · cpe:a:nodejs:node.js |
|